Error: LibGit2Sharp.LibGit2SharpException

0
Hi there! I use both a local PC and a virtual disk top. The local PC is working fine, but when I try to commit from the virtual disk top, I get the following error message. I am using the same version of Mendix studio on both local PC and virtual disk top. The repositoriey is on AWS Codecommit. Any idea would be highly appreciated. Thanks!   ---------------------------------------------------------------- - Mendix Version:Mendix-9.6.9.38960 - git: AWS codecommit -error logs: LibGit2Sharp.LibGit2SharpException: request failed with status code: 403    at LibGit2Sharp.Core.Ensure.HandleError(Int32 result)    at LibGit2Sharp.Core.Proxy.git_remote_fetch(RemoteHandle remote, IEnumerable`1 refSpecs, GitFetchOptions fetchOptions, String logMessage)    at LibGit2Sharp.Commands.Fetch(Repository repository, String remote, IEnumerable`1 refspecs, FetchOptions options, String logMessage, ProxyOptions proxy)    at LibGit2Sharp.Network.Fetch(String url, IEnumerable`1 refspecs, FetchOptions options, ProxyOptions proxy)    at Mendix.Modeler.VersionControl.Actions.GitFetchAction.Fetch(Repository repo, Remote remote, FetchOptions options) at C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.VersionControl\Actions\Git\GitFetchAction.cs:line 74    at Mendix.Modeler.VersionControl.Actions.GitFetchAction.Execute(Repository repo) at C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.VersionControl\Actions\Git\GitFetchAction.cs:line 47  
asked
3 answers
0

Issue is answered year ago, but solution did not work today for me.

 

Yesterday evening I committed and pushed my app to the Git repository without problems.

This morning I made a change, tried to commit and push the app again, 403 error. Retried several times, but alas.

 

Solution that worked for me is:

  • Create a new PAT in Mendix Developer Portal (under account). Make sure you check all the necessary boxes
  • Open the app in Mendix Studio Pro and choose to logout
  • Make a small change, save and push the app, version control will ask to login again
  • Give your username and new PAT, app will be committed and pushed.
answered
0

Hello  Zang,

                   Please verify that your GitHub account has repository permission granted for your personal access token. Without repository permission, you are unable to push, pull, and commit changes.

answered
-3

I get this error the last days all the time. Can't commit, can't update. Status pages of both Mendix and Git, don't show anything.

 

And the Team Server page doesn't show the commits, but an error instead.

 

answered