Runtime Configuration com.mendix.core.ProcessedTasksCleanupAge is not cleaning up completed processed tasks.

I am currently researching the TaskQueue functionality in Mendix Studio Pro 9.12.0. I have been trying to set the com.mendix.core.ProcessedTasksCleanupAge runtime configuration to clean up completed tasks that are over 30000 ms old. This is very frequent because I’m just doing this for testing purposes as a proof of concept. I set the runtime configuration like so:   Yet, the cleanup never happens. Is there something I’m not understanding about this process, or is it just bugged at the moment?   Sidenote: The documentation for Tasks Queues refer to this configuration as com.mendix.core.ProcessedQueueTasksCleanupAge and com.mendix.core.ProcessedQueueTaskCleanupAge. The difference being that in one instance the word “task” is singular, and in the other it is plural. However, I have not found success with either versions.
2 answers

Setting the com.mendix.core.ProcessedTasksCleanupAge to such a low value does not have an immediate effect. This is because the cleanup is performed by the cluster node (or the only node if not clustered) every ClusterManagerActionInterval, which defaults to 5 minutes.


So what is the point of requiring the value to be entered in milliseconds if it can't process in less than 5 x 60 x 1000 = 300,000 milliseconds? It seems like some bright engineer could do the math for us under the covers so we can enter values that make sense, like in minutes, hours, or days.


The documentation for this is even more strange. It says the default value is "365 days for projects migrated from Mendix 9 and 7 days for new projects or projects with an empty database." So the default value is 31536000000 milliseconds for projects migrated from Mendix 9 and 604800000 for new projects or projects with an empty database.


Maybe someone could improve this?




Locally I've got the same issue with com.mendix.core.ProcessedTasksCleanupAge while the functionality for com.mendix.core.ScheduledEventsCleanupAge runs fine. I haven't tried this setting in Mendix cloud yet.

My advice: create a ticket at