Sudio Pro Local host server startup error

With a ‘clean’ version of the App I try to run it locally, I get notified that the App starts, (the “rocket” launch pop-up), then there is no activity in the console, and after app 2 minutes there is a notification window (see question 114754) without any detail…... I noticed more people having this (or at least a similar) problem. It even seems ‘persistant’ over subsequent versions of the modeler, which might indicate it is probably more environmental, but I have yet to find a decisive solution. I already tried the following, to no avail: - cleaning deployment  - deleting the app-package and re-importing it from the teamserver - reinstalling modeler version - upgrading modeler version and converting the app (in place)  (9.6.10 and 9.6.11) - updating local Java - updating JDK - switching port number   This morning I created a “new” ServerTest App in 9.6.11, just the basic set-up, out of the box (other then fixing an obnoxious error in the Datawidget marktplace module). Got the same error. So this looks to be pointing to something environmental on the machine ….. Update 25/4 OK, this seems to “worsen"…..  I created a test App in 8.18.16 which now shows the same issue…. Suggestions welcome! Update: 26/4 suggestion was that this might be related to firewall of other security measures. Checked all relevant logs and cont find any time-stamps that related to my testing-moments.   Possible insight:  this all seems to have started AFTER installing 9.6.10 or 9.6.11…..    can something which i distributed with one of those versions be causing this ??? UPDATE! ……  with the insight provided I once more went to work trying to figure this out…….  Opening Studio Pro starts a set of tasks in the Task Manager, more specific: CefSharp. Browser.Subprocesses. So far, so good as those are associated to the visible part of the modeler. Now start to deploy locally. Up pops and OpenJDKPlatform task, which tries to pop javaw.exe. I see activity for a while and as soon as the javaw.exe disappears, the screen in the modeler pops the error-message which started all this.    SO…… WHY is my javaw.exe not working….?? Next stop, visit AdoptOpenJDK – but…… that site sadly is dysfunctional now and points to Eclipse Adoptium…… OK. download the latest version from there then ??? Yup, but NOT the most ACTUAL one, but the lastest version JDK11…. And lo_and_behold !!!!     IT LOOKED LIKE WE WERE BACK IN BUSSINESS (but the bright light of the next morning shows differently) Thanks for the insight Christian  Eventually, I got the right one. Don’t you love hidden features like that …….  OK…  this more or less confirms my suspicion that it started with downloading and starting 9.6.11… So…. comparing the Task Manager to see what is Mendix related…….  So, still unsure WHAT is causing the problem, but getting a new JDK11 from the Place_to_Be (which most definitly is NOT AdoptOpenJDK anymore, which is what Mendix has (almost hardcoded) in the Preferences, seems to fix the problem for my test project……. sometimes…. So, still no sollution and created a TICKET to proceed….   *fingers crossed*   Progress update: in resolving the issue with the help of support we have now determined it is the ADMIN port (8090) which seems to be blocked. So thanks to the suggestion too @Arjan, we are currently doing just that, trying to find the elusive port-hogger… I noticed that I forgot to answer one of Arjan's questions: no this extends down to 7.23  Update:  thanks Tim, I tried that with 8090 (as the Admin-poort seemed to cause an issue, notting runs on that poort when I start the App from the modeler but while the machine is trying to start the local-host it is totaly unresponsive to any other activity and after it fails there is again notting showing on the poort Update: through sheer luck (and LOTS of sleepless hours) I managed to find a working WORKAROUND….. it is still NOT clear what the precise issue is, but when shutting down my McAfee Realtime scan, I can once again start up a localhost session….. Still strange: notting was changed in my MxAfeef settings recently, and EACH workstation I installed 9.6.11 on gets this problem, but I can test locally again! 
0 answers