Error on publishing an App

Hi, since yesterday I got an error message on publishing a new app version and found following error message: Pipeline created at 2022-06-02T20:23:57Z [teamserver-discovery] 2022-06-02T20:24:02.934220183Z Project: c2a2b22a-49da-49c6-8b1e-a6b9330d0b7a [teamserver-discovery] 2022-06-02T20:24:02.934257006Z Determining repository type... [teamserver-discovery] 2022-06-02T20:24:03.108883182Z Found type: git [teamserver-discovery] 2022-06-02T20:24:03.109438589Z Found URL: [teamserver-checkout] 2022-06-02T20:24:31.794975561Z Project: c2a2b22a-49da-49c6-8b1e-a6b9330d0b7a [teamserver-checkout] 2022-06-02T20:24:31.794978529Z Branch: main [teamserver-checkout] 2022-06-02T20:24:31.794980638Z Revision: 0f829cc1 [teamserver-checkout] 2022-06-02T20:24:31.794984922Z Getting temporary access URL... [teamserver-checkout] 2022-06-02T20:24:31.929577081Z Cloning repository... [teamserver-checkout] 2022-06-02T20:24:31.936867393Z fatal: ambiguous argument '0f829cc1': unknown revision or path not in the working tree. [teamserver-checkout] 2022-06-02T20:24:31.936884454Z Use '--' to separate paths from revisions, like this: [teamserver-checkout] 2022-06-02T20:24:31.936887209Z 'git <command> [<revision>...] -- [<file>...]' [teamserver-checkout] 2022-06-02T20:24:31.958986512Z 2022/06/03 05:24:31 Skipping step because a previous step failed   I have done several changes in my application. Thanks and regards, Ingo  
3 answers

This is a known issue with deploying free apps hosted on Git repositories. It is being worked on. 

It does not happen on all Git-hosted apps (/revisions), therefore workarounds such as the one Tim mentioned can work. 

A different workaround (which may be easier) is to deploy through Mendix Studio (click "Publish").


Re-download your project from Git and see if you have the same problem when publishing that one. Probably not.

Then reapply the changes you have made. Start with the one you expect is causing the problem. Each time publishing is succesful, commit the change.


I had exactly the same error message as the author. Waiting for solutions~~~