Studio Pro - server failed to start. see details for the server log

Creating a blank app and running it results in the following popup in StudioPro:   There’s nothing in the Studio Pro console. Google searches and searches on the forum indicate this issue has been encountered for a while across various versions of Studio Pro. However, there aren’t many with successful resolutions. I get similar errors on version 9.15, 9.13.1, 9.12.4 of Studio Pro. Appreciate any pointers/assistance in resolving this. Thanks!
5 answers


You can try this,

Hope this helps!


Thanks for the pointer @Srilatha.

Any additional pointers as to where I need to “add or update the environment variable NO_PROXY”

Is this in a config file (if so, which one?) or thru something in Studio Pro?



Honestly speaking i never encountered this issue. But i think they are referring to this very place in the Config. Can you try the above?


Thanks Ganesh. 

I tried this.

No luck! Same error.


I do see the follow after enabling Debug (file studiopro.exe.nlog) in the Studio Pro log (Help - Open Log File Directory - log.txt)

2022-07-16 12:48:48.3190 DEBUG Mendix.Modeler.M2EEConnector.M2EEClient Sending 'echo' request to M2EE server
2022-07-16 12:48:48.3863 DEBUG Mendix.Modeler.M2EEConnector.M2EEClient Failed to send a ping to the M2EE server
Mendix.Modeler.M2EEConnector.M2EEException: Request <{"action":"echo","params":{"echo":"ping"}}> failed: <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN""">
<META HTTP-EQUIV="Content-Type" Content="text/html; charset=us-ascii"></HEAD>
<BODY><h2>Not Found</h2>
<hr><p>HTTP Error 404. The requested resource is not found.</p>

 ---> System.Net.WebException: The remote server returned an error: (404) Not Found.
   at System.Net.HttpWebRequest.GetResponse()
   at Mendix.Modeler.M2EEConnector.M2EERequest.DoHttpRequest(String json, Int32 timeout) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EERequest.cs:line 196
   --- End of inner exception stack trace ---
   at Mendix.Modeler.M2EEConnector.M2EERequest.DoHttpRequest(String json, Int32 timeout) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EERequest.cs:line 196
   at Mendix.Modeler.M2EEConnector.M2EERequest.Execute(Int32 timeout) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EERequest.cs:line 91
   at Mendix.Modeler.M2EEConnector.M2EEClient.Ping(Int32 timeout) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EEClient.cs:line 53
2022-07-16 12:48:48.4897 DEBUG lambda_method454 Timeout (100000 ms) exceeded while waiting for the M2EE server to come online
2022-07-16 12:48:48.6401 DEBUG Mendix.Modeler.Utility.FileSystem Reading: \\nahomewfs02\home01$\NK11\My Documents\Mendix\v9_12_4_POC VDI-main\deployment\log\m2ee_log.txt
2022-07-16 12:48:48.7374 DEBUG Mendix.Modeler.Utility.FileSystem Read: \\nahomewfs02\home01$\NK11\My Documents\Mendix\v9_12_4_POC VDI-main\deployment\log\m2ee_log.txt
2022-07-16 12:48:48.7374 DEBUG Mendix.Modeler.Deployment.Local.LocalRunner Exception occurred while running project locally
Mendix.Modeler.M2EEConnector.UnableToStartServerException: Unable to start server
   at Mendix.Modeler.M2EEConnector.RuntimeLauncher.EnsureStarted(String logFileLocation, Int32 serverPort, M2EEClient client) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\RuntimeLauncher.cs:line 203
   at Mendix.Modeler.M2EEConnector.RuntimeLauncher.LaunchRuntime(LaunchConfig launchConfig) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\RuntimeLauncher.cs:line 56
   at Mendix.Modeler.Deployment.Local.LocalRunner.DoLaunchRuntime(IConfiguration config, String javaExePath) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Local\LocalRunner.cs:line 234
   at Mendix.Modeler.Deployment.Local.LocalRunner.<>c__DisplayClass63_0.<LaunchRuntime>b__0() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Local\LocalRunner.cs:line 223
   at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass1_0`1.<Do>b__0(Object s, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Utility\BackgroundUtil.cs:line 29
   at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
   at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)



Not sure if this error was present before or only after I entered the proxy value!!




Thanks Ganesh.
This was a 'blank' app created afresh.

I suspect that it's an issue with my system/network, too.

Thanks for your help. I will post updates on this thread if/when I address the issue.