All the content disappaeared after my Mendix suddenly blinked back

hello!I am using Mendix version 9.5.0. When I was creating a page today, Mendix suddenly got stuck and then went back out. When you open it again after blinking back, all the page contents in the software are gone. But the page I created is still there, and there's no content in it. I tried a few different ways to open it, but it was still the same inside. Has anyone ever been in this situation? How should this situation be resolved? Thank you very much!
2 answers

Hi Chen,


I thought you haven’t saved the changes made in the page which you done after creating the page.So,the data which hasn't saved would have vanished.


When you create a page, its directly added (saved) to the model. When making changes to a page these changes re only saved when you save it (CTRL -S), close it and saved changes or when you run the app and save changes. If the model is closed differently without an active save, changes will be gone.


So answering your question: This can not be resolved other then model it again.

And yes I have encountered this as well, however annoying it happen me 2-3 times in 12 years of using Mx.