Since update to 9.18.0 committing object in Nano and Microflows stops execution

My app worked fine in 9.16, 9.17, 9.17.1 but since I updated Mendix Studio Pro and my project to 9.18.0 creating objects in the app failed. Using log messages and debugger breakpoints I am able to execute till the commit function in the microflow or nanoflow. But the next step in the micro or nanoflow is never called. If I disable the commit step or function (for example create an object without committing) then the next step is called and works fine. However, the object is not committed to the database (of course). If I enable the commit then I can find the object in the database. But the rest of the micro or nanoflow is not executed. Also the function is not returning to the previous micro or nanoflow which called that function. Strangely I don't see any error or warning. Neither in the browser console nor in the Mendix Studio Pro console or debugger.   I tried also 1. To remove all entity events (before/after create, commit, etc.) 2. To give full read/write access to all users for all objects 3. Deleting the deployment folder (with all the files/database within) 4. Changing the auto-commit handling behavior based on Nothing helped.   Interestingly if I copy/paste the same object, create a new object or create a new app I don't see this problem. Is there maybe something wrong with the settings or conversion from 9.17.x to 9.18? Or the runtime itself? If I roll the app/back to 9.17.1 or 9.17.0 it works perfectly fine.
0 answers