Association is removed after show page in microflow

I'm having a problem with my associations. I'm trying to add certain “Zorgverlener” objects to a “ZorgverlenerBulk”. So I created this association.  First I create a new Object of “ZorgverlenerBulk”. Then I created a page where a “Zorgverlener” can be selected. In a MF I associate it to the ZorgverlenerBulk. (I checked with a retrieve by association if the Zorgverlener is associated to the ZorgverlenerBulk, which is the case.) On the page “ZorgverlenerBulk_ViewList” I have a data view of ZorgverlenerBulk and inside I want to show my list of associated Zorgverleners, as below. But the list is empty. Also when I use a microflow to retrieve the list, the list is empty. I checked the ZorgverlenerBulk object, it's the same one. But how come there are no Zorgverlener objects associated with it anymore? Btw, I don't want to commit the list or the ZorgverlenerBulk.   EDIT: I did some experimenting and this is just really weird. It seems there's something wrong with the parameter Zorgverlener (as below) When I do a random retrieve, it's added to the list, when I do a retrieve of an object that is not the Zorgverlener (id != $Zorgverlener) everything works fine, but when I do a retrieve from the Zorgverlener itself (id = $Zorgverlener) it finds the Zorgverlener object but it's not added to the list! I'm am beyond confused right now!
2 answers

Hey Marijn,

You have to choose database, in the place of association,

into the datagrid,

As soon as you click database, you will see an option of ZroverlenerBulk_Zorgverlener on the very top of database selection table,


Select that association (from the database), 

Let me know if you face any issues,


Hope it helps!!


You said you weren’t committing the list of Zorgverlener objects or the ZorgverlenerBulk object.

However, I see you are retrieving from the database in your screenshot. This will get a fresh instance of the object and you’ll lose the association between the two which wasn’t committed, which could explain why your list is empty.

I hope this helps.