Hi,   I have a question about a a conversion flow I ran not to long ago. I upgraded the Email_Connector module from the appstore, however due to custom changes I moved the old domain model to a new Module. And then imported the new version from the appstore. Now we are trying to convert the EmailTemplate from the old domain model to the new domain model however there is a problem with commiting this object. The error that I get is shown below:    ConnectionBusRuntimeException: Could not find model guid entry for entity 'Email_Connector.EmailTemplate'   I have tried restarting the app, and running model reflection but that didnt help.  
2 answers

Hi Martijn,


I think the MxModelReflection has assigned different identifiers from your old domain model to your new Model. I assume you already refreshed MxModelReflection. If not, try that. 


There is a template migration utility:

See if that helps for you (I’m not sure if it can overcome the Module change you made).


When it will not work after the refresh, or you already refreshed, and the migration doesn’t work you need to re-built the templates. 


Go Make It



I indeed refreshed the MxModelReflection, for now we manually recreated the Templates but thank you for pointing out that there is a Template migration utility.