An unknown error occurred while starting the server

Hello,   When I try to run application I got this error message. I find some solutions in forum but those are not working for me. Can you help me with that?   Thank you,       Mendix.Modeler.M2EEConnector.M2EEException: The server encountered an error.    at Mendix.Modeler.M2EEConnector.M2EEResponse.CheckSuccess() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EEResponse.cs:line 57    at Mendix.Modeler.M2EEConnector.M2EEClient.UpdateConfiguration(Dictionary`2 config) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\M2EEClient.cs:line 173    at Mendix.Modeler.M2EEConnector.StartupManager.PerformStartup(StartupInfo info, IM2EEClient client) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\StartupManager.cs:line 51    at Mendix.Modeler.M2EEConnector.RuntimeController.Start(StartupInfo info, LogLevel autoSubscribeLogLevel) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.M2EEConnector\RuntimeController.cs:line 135    at Mendix.Modeler.Deployment.Local.LocalRunner.<>c__DisplayClass70_1.<RuntimeLaunched>b__1() in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Deployment\Local\LocalRunner.cs:line 336    at Mendix.Modeler.Utility.BackgroundUtil.<>c__DisplayClass1_0`1.<Do>b__0(Object s, DoWorkEventArgs e) in C:\Users\Autobuild\workspace\AppStudio4.0-Build\modeler\Mendix.Modeler.Utility\BackgroundUtil.cs:line 29    at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)    at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
4 answers

I try every single one of them and still not working.

By the way it is first time I run the app. I got firewall warning and I allow mendix app.


There are multiple things you can try to find the root cause and run the app,


  1. Clean the deployment directory and try running the app
  2. restart the modeler and try running the app
  3. make a brand new project and run the app
  4. change the filesystem location where the project is being saved on DISK and create a brand new project and run the app
  5. first time when you run the app, you might have got a Firewall warning on allowing the mendix app to expose port to the network. You should allow it or you should disable firewall momentarily to see if that is the cause

Did you try all these? Let me know if any of this worked.


Hello Dear Mücahit,


I have the same problem and tried all the solutions in the forum. If you solved the problem can you help me please ?


Thanks a lot.


Hi Mucahit Celik,


This error is getting because of your localhost is running in background. Open your settings tab in your app and change the port or kill the locahost PID by using cmd prompt


Hope its help!!!!