Urgent issue

0
Hello, Facing a issue in studio pro 9.12.4 when clicked run the app, it showed an warning that port 8090 is already in use and asked to change the port number for the application.    
asked
2 answers
3

Hello Vaishnavi Deshmukh,

You are facing this issue because of any one of issue mentioned;

  1. Another mendix application is running in background.
  2. Mendix application is not closed properly.

To overcome the issue simply try restarting your PC. If the issue is not solved yet then try the mentioned steps;

  1. Go to settings in studio pro.
  2. Under Configuration tab click on edit.
  3. Go to server tab.
  4. Change the runtime port and admin port.
  5. Now try running your application.

Hope my answer helps. Reach me out for any queries.

answered
0

Hello Vaishnavi,

 

The error says the port number is already, which means some other application or something is using that port. You can either do things :

 

You can either kill the process running in the port or change the port number of your application from the App Setting

  1. Change the port number of your application.
    App setting → Edit the database→ Server –> update the runtime port number.

 

Ref: 

 

  1. Run the process running on the port number :

            Follow this post: https://medium.com/@javatechie/how-to-kill-the-process-currently-using-a-port-on-localhost-in-windows-31ccdea2a3ea

            and re-run your application.

 

answered