Timeout Error While Downloading a Project When Connected to Wi-Fi

Hello everyone,   I've been facing a recurring issue while attempting to download Mendix projects specifically when connected to Wi-Fi. It's important to say that I don't experience this problem with other websites or apps, and the issue does not happen when my laptop is connected to mobile internet. The problem displays as a Timeout Error that occurs consistently during Mendix project downloads. I have a stable and reliable Wi-Fi connection, so I don’t really know why this issue appears only with Mendix. Are there any known fixes or workarounds that can permanently solve this issue? I've tried various troubleshooting steps, such as clearing browser caches and restarting my router, but these didn’t help me. Any advice or suggestions would be very helpful.   Thank you if anyone can help.   Example (I took different errors each time. I explained the original problem above.) ------------------- com.mendix.systemwideinterfaces.MendixRuntimeException: java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout expired: 30006/30000 ms     at com.mendix.util.classloading.Runner$.withContextClassLoader(Runner.scala:23) Caused by: java.io.IOException: java.util.concurrent.TimeoutException: Idle timeout expired: 30006/30000 ms     at org.eclipse.jetty.util.SharedBlockingCallback$Blocker.block(SharedBlockingCallback.java:221)     at org.eclipse.jetty.server.HttpOutput.close(HttpOutput.java:623)     at java.base/sun.nio.cs.StreamEncoder.implClose(StreamEncoder.java:341)     at java.base/sun.nio.cs.StreamEncoder.close(StreamEncoder.java:161)     at java.base/java.io.OutputStreamWriter.close(OutputStreamWriter.java:258)     at com.mendix.util.using.Using$.using(Using.scala:8)     at com.mendix.modules.debugger.internal.DebuggerHandler.doProcessRequest(DebuggerHandler.scala:66)     at com.mendix.external.connector.MxRuntimeConnector.$anonfun$processRequest$1(MxRuntimeConnector.scala:50) “
1 answers

Is the WiFi you are using at a school or place of work? It could be that there is a proxy server in place that controls access to the internet. You can add proxy server settings in Studio Pro via the Preferences option in the Edit menu.


I hope this helps.