Error: The selected page MxObject.Details should accept a parameter of type MxModelReflection.MxObjectType, but expects a parameter of type MxModelReflection.MxObjectType instead.

3
In Mx.StudioPro 10.1.x  (In 10.0 it works fine)     The selected page 'MxObject.Details' should accept a parameter of type 'MxModelReflection.MxObjectType', but expects a parameter of type 'MxModelReflection.MxObjectType' instead.   The error is caused by the combination of Mx Model Reflection and the modules referring to the MxObjects_Details page, like Excel Importer and Excel Exporter.   There is a workaround presented by the support team: Double-click on the reference selector that generates the error -> In the Properties window, click on the "Select" button of the “Go-to page”. Choose a different page. For example, the MxModelReflection.Microflow_View, then click OK on the Properties window. Re-do step 1, but now choose the MxModelReflection.MxObject_Details page. The parameter mapping will be reset, and the error will be gone.   It works, the post is here for you to find and don’t need to raise a ticket.   Go Make IT .       In Mx.
asked
2 answers
1

This is a bug that is fixed in version 10.2.  https://docs.mendix.com/releasenotes/studio-pro/10.2/

 

We fixed an issue where importing a module from Studio Pro 10.0.0 incorrectly triggered the consistency error CE7411 if the module contained a widget that called a page outside the imported module (for example, the Go to page of a reference selector in the Excel Importer module). (Tickets 192867, 193026, 193410, 193736)

answered
6

Use the workaround:

  1. Double-click on the reference selector that generates the error -> In the Properties window, click on the "Select" button of the “Go-to page”.
  2. Choose a different page. For example, the MxModelReflection.Microflow_View, then click OK on the Properties window.
  3. Re-do step 1, but now choose the MxModelReflection.MxObject_Details page.
  4. The parameter mapping will be reset, and the error will be gone.

 

Thanks Support!!!!

answered