Mendix 10 role-based home page not triggering microflow

Hi all,   Anyone having issues on Mendix 10 with triggering microflows as role-based home page targets?   I’m following the documentation for setting up the Forgot Password module   And I just found out that role-based home page microflow targets aren’t getting triggered in Mendix 10. It’s not just that Nav_GuestHomePage microflow the documentation requests setting up, it seems to be any microflow set up as a role-based home page. Adding a breakpoint to the first activity in the role-based home page microflow doesn’t trigger the debugger. The user simply gets redirected to the default home page. Setting pages directly as role-based home page targets, however, works fine.   I’ve tried a bunch of stuff, enabling/disabling “Apply entity access”, triple-checked entity access rules, triple-checked assigned module roles to user roles, tried setting the role-based home page microflow on an anonymous or regular user role, checked all jars in the userlib, to no avail. To troubleshoot I’ve tried setting up exactly the same project and settings on Studio Pro 9.24.2, 9.24.3, 10.0.0, 10.1.1. Role-based home page microflows seem to get triggered fine in 9.24.2 and 9.24.3. A breakpoint to the first activity of this microflow on these versions of Studio Pro triggers the debugger as expected. Not the case on 10.0.0 and 10.1.1. In fact, as soon as I convert a 9.24.2 project to 10.1.1, that role-based home microflow stops getting triggered and the default home page gets loaded.   Don’t think I can get the Forgot Password module working properly without this functionality and also wouldn’t like to come up with my own Forgot Password setup.   Can anyone clarify whether I’m missing something or whether this is a Mendix 10 bug/known issue?   Thanks    
1 answers

Hi Raul and Liam,

This is a known issue that has already been fixed in Mendix 10.2.0. It will be released on August 29th. 

We appreciate your patience and cooperation!