How to solve CE9804 – Java dependency failed... after upgrade to 10.3.0?

4
I upgraded from 10.2.x to 10.3.0 yesterday and my App stopped building.   After opening it in Studio Pro, the error CE9804 appears and build is impossible (details below). The new feature “Java Dependency Management” seems to be broken.   In my case org.apache.commons:commons-codec:1.15 could not be found in Maven repo. I looked there and it is true, the path is incorrect.   What to do?   *************** FAILURE: Build failed with an exception. * What went wrong: Execution failed for task ':copyDependencies'. > Could not resolve all files for configuration ':implementation'.    > Could not find org.apache.commons:commons-codec:1.15.      Searched in the following locations:        - https://repo.maven.apache.org/maven2/org/apache/commons/commons-codec/1.15/commons-codec-1.15.pom      If the artifact you are trying to retrieve can be found in the repository but without metadata in 'Maven POM' format, you need to adjust the 'metadataSources { ... }' of the repository declaration.      Required by:          project : * Try: > Run with --stacktrace option to get the stack trace. > Run with --info or --debug option to get more log output. > Run with --scan to get full insights. * Get more help at https://help.gradle.org BUILD FAILED in 1m 20s ******************
asked
2 answers
5

You’ve already isolated it to the OIDC SSO, but if you’d like to fix the issue for the time being, you can open up settings on the OIDC module, and change the dependency library to fix this. Looks like OIDC still has the apache web group name here, just change it to commons-codec and it worked for me.

 

answered
0

The new version of the OIDC SSO module (v2.3.1 from Nov 15) has solved the issue in a systemic way.

answered