Error on Pull on 9.24.6 - saying I need to commit to be able to pull however I have not made any changes, so shouldnt need to commit.

Good Evening,   I am working on an app on studio 9.24.6 with a colleague. The last couple of times where I have tried to pull my colleagues changes it comes up with this error.      I haven't made any changes. Anyone know how to stop this and be able to get the updated version?   Thanks  
2 answers

Hi Jessica,


It seems there is a file somewhere in your project that is marked by your version control system as changed even though it is not showing that in you Studio Pro.  There are a few steps you could try to remedy this:


First, you could try making an inconsequential change in Studio Pro, e.g. move an element on a page, and then commit.  This may pick up all the changes in your project files and mark them as committed.


Next, you could try to download a version management tool and manually inspect your project files to see what the system is seeing as an uncommitted change and manually remedy the issue.


Last, if you have no local changes, you could delete and redownload the project branch, as this should remove any chance of having an uncommitted file in the project.


Hope this helps!


Hi Again,


I tried making a small change and committing and it came up with the below error. It is not showing my commit on the dev portal.


Any ideas how to fix this please?