Community Commons 10.0.5 + Mendix Studio Pro 10.6.2: Java dependency synchronization failed because a required dependency could not be resolved.

2
FAILURE: Build failed with an exception. * Where: Build file 'C:\Users\<>\My Documents\Mendix\vendorlib\temp\build.gradle' line: 2 * What went wrong: Plugin [id: 'org.cyclonedx.bom', version: '1.8.1'] was not found in any of the following sources: - Gradle Core Plugins (plugin is not in 'org.gradle' namespace) - Plugin Repositories (could not resolve plugin artifact 'org.cyclonedx.bom:org.cyclonedx.bom.gradle.plugin:1.8.1') Searched in the following repositories: Gradle Central Plugin Repository * Try: > Run with --stacktrace option to get the stack trace. > Run with --info or --debug option to get more log output. > Run with --scan to get full insights. * Get more help at https://help.gradle.org BUILD FAILED in 1s  
asked
3 answers
1

Hi Alex,

 

I mentioned this solution in a few Forum questions that are related: this error happens depending on how the Proxy is configured in your Network. Some Gradle Repositories could be blocked, and that's why you are receiving the error while trying to reach the Gradle Central Plugin Repository.

 

To solve this issue you need to open Studio Pro, go to Edit > Preferences:

image.png

 

And then in the Deployment tab, look what you already have configured at the bottom on Use custom repositories (please comment what settings you have):

image.png

 

By default (when you set this property to No), Mendix uses the following two repositories (It seems like the first one is being blocked):

image.png

 

Something you can try :

  1. Set use custom repositories to Yes.
  2. Leave the default values as it is.
  3. Try to run the project and if the error still shows up, try restarting Studio Pro.
  4. If that still doesn't work, set use custom repositories to No.
  5. Restart Studio Pro, and next time you run your project it should work.

 

If that method doesn't work, try these Gradle repos (one by one) with use custom repositories set to Yes:

gradlePluginPortal()
mavenCentral()
jcenter()
google()

 

I hope that also fixes your issue, best regards!

answered
0

I tried the steps of Oswaldo but did not work for me, same as Alex.

Even we turned off the VPN in my local, still the issue did not go away.

I did download the Gradle 8.6, update my gradle repository in the App setting and download again the Community commons latest releases. It solved the issue from my side.

answered
-1

It was 100% a proxy issue.

Open C:\Program Files\AdoptOpenJDK\jdk-11.0.3.7-hotspot\conf\net.properties and add

http.proxyHost=your.proxy.url

http.proxyPort=your.proxy.port

https.proxyHost=your.wproxy.url

https.proxyPort=your.proxy.port

restart computer, and issue is fixed!

answered