Empty fields

Hi,   Currently I encounter a weird issue in Mendix. After adding a new item to an entity (by datagrid2), the object is saved successfully with all the information I have entered.   When I edit / view the added object, some fields are empty. It's different kind of fields like a textfield, reference selector and dropdown.   When I do a refresh of my browser, the fields are filled in properly. Some facts: Mendix Studio Pro 10.6.1 Safari on MacOS Edge on MacOS and Windows I have re-added a Form page with the attributes Other entities does not have this problem Same issue persists with the old datagrid, so it's not a datagrid issue Anyone else experience this issue?    
3 answers

Weird indeed. No, I have not seen or heard of this behavior, and hope not to as nobody is a fan of this type of irratic strange behavior.

So, excluded causes are:

- the DataGrid2, since also datagrid has the issue

- browser, since you tried Opera an Edge

- OS, since you tried MacOs and Windows

- type of attribute, since it happens on several types

but you do see this working fine on other entities.

Things to try:

- is it related to some odd storage-problem. If it happens on different environments, this is not likely.

- hope it is solved if you replace the entity with a new one. Probably a cumbersome task, but who knows, it might help.


Based on the provided info, i guess you need to refresh the entity you changed/committed. So if you save the data from a popup f.i. and you only close the popup afterwards, the data is not refreshed. Enable 'refresh client' on the change action of the entity in the microflow to refresh the data in the grid.