Cant able to open the Modeler

Hey all,   I'm trying to open the Mendix Modeler 9.12.2, have tried many times still i can't open it. I tried reinstalling the modeler and restrated my machine, yet no luck. But I can able to open other versions!    Any solution for this?   Thanks in advance!
7 answers

Hey Guys,


Finally, I can open the modeler. With the help of the Mendix Support Team, I have rename the SQLITE file and I'm able to open the modeler.


Thank you for all your insights.




Copying your answer from Mendix support here so that the question can be marked as resolved and it's easier to find for others:




That certainly sounds like an issue with the Studio Pro application. As other versions run successfully and the issue with this specific version, I would look at the Event Viewer in Windows to see if there are any error messages there that say what is happening.


To do this, first try to start Studio Pro. Now type "Event Viewer" in your Windows Start menu to load the application event viewer application. In there, look in Windows Logs -> Application and see if you can see any errors from your attempt to load Studio Pro. It should hopefully flag up the error, and tell you what is causing it to fail.


I hope this has helped. Good luck.


Hi Karthikeyan,


If I understand you in the right way, Here are some insight maybe would assist you:


  1. Check System Requirements:

    • Ensure that your system meets the minimum requirements for Mendix Modeler 9.12.2. You can find the system requirements in the Mendix documentation.
  2. Check for Error Messages:

    • Look for any error messages or logs that might provide information about why the Modeler is not launching. Check the event viewer on your machine for any related errors.
  3. Run as Administrator:

    • Try running Mendix Modeler as an administrator. Right-click on the Mendix Modeler shortcut or executable and select "Run as administrator."
  4. Compatibility Mode:

    • Right-click on the Mendix Modeler executable, go to "Properties," and under the "Compatibility" tab, try running it in compatibility mode for an earlier version of Windows (if applicable).
  5. Antivirus/Firewall:

    • Temporarily disable your antivirus or firewall and check if the issue persists. Sometimes, security software may interfere with the normal functioning of applications.
  6. Reinstall .NET Framework:

    • Mendix Modeler relies on the .NET Framework. Try reinstalling or repairing your .NET Framework installation. You can download the latest version from the Microsoft website.
  7. Check for Updates:

    • Make sure that your operating system, graphics drivers, and other essential software are up to date. An outdated system or driver could cause compatibility issues.
  8. Clean Installation:

    • Uninstall Mendix Modeler 9.12.2, ensuring that all associated files and folders are removed. Then, perform a clean installation of Mendix Modeler 9.12.2.
  9. Check Disk Space:

    • Ensure that you have enough free disk space on the drive where Mendix Modeler is installed. Insufficient disk space can sometimes cause applications to malfunction.


** Kindly  accept my answer if it assist you to solve your problem.


Hey Guys,


Thanks for your input! I have tried all the insights provided. Still no luck.

Please do let me know is there any other solution for this.



Mendix Modeler.PNG


Just a few checks that as far as I can see haven't been mentioned yet:


  • Install Mendix Studio Pro in a different directory. Especially if you have it set to a cloud destination like OneDrive, make sure you install it on a local drive instead.
  • Be sure to follow all the Troubleshooting steps mentioned here. Mendix versions before 9.13 need a different Java JDK, so that might explain why it's specifically 9.12 that's causing you issues
  • Consider upgrading to a newer Mendix version either way, because there are security vulnerabilities that have been fixed since that leave your application vulnerable if you don't upgrade.

Please look into the userlib folder for duplicate Jar files, if it is delete and try again. if the issue still persists, try submitting a incident to Mendix.