Unable to deploy or update a free App anymore to mendix cloud

I have a normal App in test which is a free app currently. The App has already been published before, but is no more able to be updated since two days, after I fixed number of bugs. Local deployment has no problems, and runs perfectly. Just I am not able to publish it over mendix studio pro. Currently I am using studio pro 10.6.5. When I pushed the publish button, the deployment process hangs forever, no feedback, no error warning, just hangs forever. Even the previous app on the cloud could not wake up. The waking up state keeps forever.  What is wrong here?
2 answers

From status.mendix.com


Mar 19, 2024
Mendix Cloud free apps deployment issue
Resolved - The issue is now resolved after a fix was rolled out. 
We identified an issue with the network configuration that was restricting public traffic for the newly deployed applications. 

In case you are still facing any problems with your free app, please contact Mendix Support team.




Thanks for the feedback.

The problem has been solved however in another way: 

I need to unlink the app, and re-publish it again, then it works. I don't know what was the reason behind, otherwise, publishing would hang forever without any feedback. I tried the version 10.6.5 and 10.8.0 both, the results were the same. 

With 10.8, even the app was published successfully, the app was not accessbible.