Failed to checkout Remote Repository when downloading the App from Teamserver

I had the app installed locally, however there were multiple copies so I deleted them.    When I tried to open the App by Clicking on Edit With Studio Pro and downloading the app, I get the following error.    LibGit2Sharp.LibGit2SharpException: request failed with status code: 500 at LibGit2Sharp.Core.Ensure.HandleError(Int32 result) in /_/LibGit2Sharp/Core/Ensure.cs:line 155 at LibGit2Sharp.Core.Proxy.git_clone(String url, String workdir, GitCloneOptions& opts) in /_/LibGit2Sharp/Core/Proxy.cs:line 278 at LibGit2Sharp.Repository.Clone(String sourceUrl, String workdirPath, CloneOptions options, ProxyOptions proxy) in /_/LibGit2Sharp/Repository.cs:line 854 at Mendix.Modeler.VersionControl.Actions.Git.Requests.Clone.GitCloneLibGitRequest.ExecuteRequest() in Mendix.Modeler.VersionControl.Git\Actions\Requests\Clone\GitCloneLibGitRequest.cs:line 50   Downloading & Running any other app works fine locally. I was working on this App just yesterday and could commit fine. But today after the deleting the directory of the local version I am getting this error. I also tried to change the directly location but nothing works.    I also tried to clone the team server URL but that asked for git authentication - which I don't seem to know cause we never set that up.    Using 10.7.0 - Can't find it in the list. 
1 answers


Try to download the application by changing the folder location. I had a longer file path with multiple nested folders which caused the issue. The maximum character allowed for file path is 260.  I changed it to simple file path like D:/MendixApps/DemoApp which worked. 


Hope it helps!