Failed to connect to the specified repository. Getting Git Error.

0
Hi there,  I am getting this error on my corpo laptop (Having Zscaler authenticated), I am unable to create any app in local with Enable Online Services clicked Yes. And also, when I try to open app from web Edit in studio pro I can't open it getting some git error as follow     Error -> LibGit2Sharp.LibGit2SharpException: failed to send request: The operation timed out    at LibGit2Sharp.Core.Ensure.HandleError(Int32 result) in /_/LibGit2Sharp/Core/Ensure.cs:line 155   at LibGit2Sharp.Core.Ensure.ZeroResult(Int32 result) in /_/LibGit2Sharp/Core/Ensure.cs:line 173   at LibGit2Sharp.Core.Proxy.git_remote_connect(RemoteHandle remote, GitDirection direction, GitRemoteCallbacks& remoteCallbacks, GitProxyOptions& proxyOptions) in /_/LibGit2Sharp/Core/Proxy.cs:line 2172   at LibGit2Sharp.Repository.ConnectToAnonymousRemote(RepositoryHandle repositoryHandle, String url, CredentialsHandler credentialsProvider, CertificateCheckHandler certificateCheckHandler, GitProxyOptions proxyOptions) in /_/LibGit2Sharp/Repository.cs:line 746   at LibGit2Sharp.Repository.ListRemoteReferences(String url, CredentialsHandler credentialsProvider, CertificateCheckHandler certificateCheckHandler, ProxyOptions proxyOptions) in /_/LibGit2Sharp/Repository.cs:line 702   at Mendix.Modeler.VersionControl.Git.GitRemoteConnector.ListRemoteReferences(String remoteUrl) in Mendix.Modeler.VersionControl.Git\GitRemoteConnector.cs:line 20   at Mendix.Modeler.VersionControl.Operations.Git.GitGetBranchesOperation.ListRemoteBranches(String remoteUrl) in Mendix.Modeler.VersionControl.Git\Operations\GitGetBranchesOperation.cs:line 100   at Mendix.Modeler.VersionControl.Operations.Git.GitGetBranchesOperation.GetBranchesRemotely(String remoteUrl) in Mendix.Modeler.VersionControl.Git\Operations\GitGetBranchesOperation.cs:line 93   at Mendix.Modeler.VersionControl.Operations.Git.GitGetBranchesOperation.Execute(GetBranchesRequest& request) in Mendix.Modeler.VersionControl.Git\Operations\GitGetBranchesOperation.cs:line 45   I tried -> Mendix Community - Question Details   Mendix Community - Question Details   & Mendix Community - Question Details This also but I don't know what URL I shall give to my IT dept.  Meanwhile someone suggested me "You need to add CA Certificate of Zscaler to your Jdk securiies and I did this Mendix Community - Question Details followed this one.    I am still facing same issue.  Please tell me what should I do? And why there isn't any option for GitHub and other repositories? I could have tried with another repository Right?   Maybe maybe..
asked
1 answers
0

I would suggest you to solve this issue outside Studio Pro, via command line or by using a tool like TortoiseGit. Please, see this post for details:

https://vstram.medium.com/how-to-clone-a-mendix-project-from-teamserver-without-using-studio-pro-74eee72d9068

 

answered