Association Setting - Different Behavior in Mx Cloud than in Modeler

I have 2 entities, Contact and Appointment, that are have a 1 to many association (each Appointment can be association with many Contacts).  In a page in my app, I have a dataview which points to Contact and a nested dataview which points to Appointment via association.  Also in this page, I have a Calendar widget that displays a number of appointments.  When an appointment is clicked, a microflow is executed which sets the association described above between Appointment and Contact.  The Contact object is not committed when this association is set, however Refresh in Client is set to Yes. When I run this in the Modeler, clicking an appointment results in information regarding the clicked appointment appearing in the nested dataview. When I run this in my Mendix Cloud Acceptance environment, clicking an Appointment does not change or update the (empty) nested dataview. I have put in place a workaround of close and reopening the page (not my choice of approaches due to resource usage, time, etc.), however I thought I would put the question out to the community and see if anyone has any ideas about what may be happening here.  One note:  this app is in version 5.21.1 I have included screen shots below: Page before appointment is selected:   Page after appointment is selected in Modeler Page construction from Modeler Any help appreciated
1 answers

I've ran into some weird issues with the Calendar before, in my case those were timing issues. A lot of stuff in the Calendar happens async, I wouldn't be surprised if the change actions are not yet completed when the refresh is executed. 
Locally everything is instantaneous, but in the cloud there is a latency between requests which could cause something like this. 

I'd recommend to start looking at the requests (through the dev tool) and see if the requests are started or finished in a different order in the cloud vs locally.