Weird intermittent issue when returning to a page with a datagrid on 6.10.1: empty grid

Hi, We have upgraded a couple of projects to 6.10.1 and noticed an issue that happens from time to time: From a page with a datagrid, choose to create or edit an entry.  The detail page has has datagrids that relate to the context entity. Play around in those grids Save the detail page The first data grid page shows an empty grid. Not only the selected row is gone, but the datagrid is completely empty.   Navigating somewhere else and returning to that same grid page sometimes causes data to be displayed again, mostly I need to use ctrl-F5 to actually get the data again. It seems the data is still there, but the grid somehow lost track of it. The detail page needs to have some complexity for this to happen. Basic edit page of single entity works fine. I have seen this in two different projects, but it is not easily repeatable.   Edit: I have a repeatable case. I will submit a ticket: 47673   Edit 2: 6.10.2 fixes this issue, but 6.10.1 has another issue with listviews in a tab container, which is not solved. See here
1 answers

The problem has been solved in Mendix version 6.10.2 released just today! Whoop!