openid.mode:error openid.error:0x301: Realm verification failed

Hi guys When I am trying to login into our app with my Mx account I get this error in Production and local environment but not in Acceptance (I get logged in there with same Mx account):   Error openid.mode:error openid.error:0x301: Realm verification failed (9) for: http://localhost:8080/openid/callback openid.ns: Try again or contact if this problem persists   When debugging the AppCloudServices I see this remarkable logging: Found local discovery of RP return_url endpoint.   What I already tried and didnt work out were: - delete cache and try again - reinviting to the project by Technical Contact   Furthermore, the app makes use of Saml 2.0 (which to my expectance has no role in this issue).   It seems like a conflict in openID handling in Mendix to me.... Anyone an idea how this problem is caused or could be traced/solved ?
1 answers

Hi Enzo,

I am curious: can you spot any relevant differences between acceptance- and production environment-settings?

"Realm verification failed" is a message you can get when your SSO settings aren't as recommended, you can look at this part of the api documentation: to see if that brings you closer to a solution ("realm verification failed' is covered here as well)