session timeout configuration

For a sessiontimeout of 30 seconds, after no activity of a user when the browser is still open , am doing the following configurations in modeler 7.6.0. settings -> edit configurations -> custom SessionTimeout: 30000  EnableKeepAlive: false But the above is not working. Any suggestions ?
1 answers

There are actually 3 settings that affect session timeouts:

  • SessionTimeout
  • ClusterManagerActionInterval
  • EnableKeepAlive


The short version of how it works: the Cluster Manager runs every ClusterManagerActionInterval milliseconds and checks for any sessions flagged for removal. Sessions are flagged for removal after the last user activity was at least SessionTimeout millseconds ago. If EnableKeepAlive is turned on, simply having your browser open in the Mendix app will keep the session alive.

Full documentation of these options is available here.