Automatic commit of changes for cloud deployment

Hi,   Changes in my local(Modeller) are autocommiting to cloud. I havenot changed any settings in modeler to autocommit. Its commited with the comment "Automatic commit of changes for cloud deployment." which I can see from history. How to avoid this issue? any pointers on this?
2 answers

Hi Nirmal,

This happens when you click “run” in the modeler. Run will do a deployment to the sandbox environment. To test locally on your computer, you want to click the down arrows next to “run” and choose “run locally”


Can you please remove this counterintuitive option? After I tried to upgrade from Mendix 6.5.1 to 7.23.3 I hit run and the 7.23.3 version was committed to the repository without asking if I was sure!!!
So the upgrade was committed to the cloud! Absurd. In Mendix 6.5.1 the run localy is default. But in 7.23.3 it is default the first time!