The given Queue with number: X was not found in the ThreadPoolManager

The processqueue is correctly working and implemented. After a while (days, weeks) the ProcessQueue configuration gets corrupt and stops working. Calling the java action AppendNewActionToQueue returns the following error The given Queue with number: X was not found in the ThreadPoolManager The problem can be resolved manual by: 1) make a copy from the corrupt processqueue configuration  2) delete the corrupt processqueue configuration  The manual solution isn't sufficient and preventing the configuration from getting corrupt would be way better. Comparing the corrupt and healthy processqueue configuration records does not provide an answer... Anyone an idea? Update   The problem is solved by implementing a solution from another thread. On the initializeQueue, the retrieved QueuedActions are commited via the commitInSeparateDatabaseTransaction java action. I don't know what exactly when wrong but the problem is solved. 
0 answers