Unable to run my application locally as the modeler is unable to find a part of the path to a widget.

When i run my application locally in the domain modeler I receive the following error:  "An error occurred while deploying. Could not find a part of the path: [then the path name of a widget file]" The widget file is the Clickable Container widget from the Mendix store and is used within my project.  I have attempted the following steps to resolve the issue:  Restart the modeller Delete the widget file and reinstall the widget from the Mendix store Download a local copy from the version control server and delete my existing local copy (this worked for a while! But the error returned).    Has anyone experienced this before? Any ideas on the cause/potential fixes? Thanks!   
3 answers

I've had this problem before (about 3 times now) Version 7.10 Mendix. I had to delete my local copy and download a new one. I've had the problem again later same as you and decided I wasn't going to delete and download again.

What I tried then was to unpack the widget.mpk it was complaining about.
In my case it said: could not find part of path: blablabla Drawline.js I  believe it was.
I then went to the widgets folder and unpacked the Drawline mpk I found there into the folder.
Which generated a folder named Drawline containing the xml and the javascript file it had been complaining about. It probably isn't how you're supposed to solve this error but it beats deleting and downloading the quite big project again -.-

Hope this works for you too (if you decide to try it)


I filed a support ticket to Mendix and they think this problem occurs when you make use of folder redirection or server back-ups. 

"I checked with our R&D Team and it was confirmed that network shares have too much latency for Desktop Modeler to work correctly. As a work around it is recommended to map a drive letter to the mounted file system so that the paths looks like this: `Z:\Documents\...`."
"I checked with our R&D Team and it was confirmed that Desktop Modeler is intended to use the local hard drive for file storage and only when it is installed on Parallels on Mac the "network share" is supported (in truth the Parallels network share is still the same computer)."

Personally, this didn't help me very much as even the local drive of my laptop is back-up-ed by our servers, but maybe this could help you.


I got the error message as well. Even for widgets that I do not use (anymore) in the project.

In my case the problem lay in the browser cache. It only occurred when I opened the local application in Firefox. When I opened the app in Chrome it worked ok.

The resolution was to delete all cookies and website data for localhost in Firefox and now the error is gone.