Issues running locally - page doesnt open

I have migrating apps to Mendix 7. I wanted to look at some functionality in a different app, still in Mendix 6.4.1. When I try to run this app locally I log in but the login page is redisplayed. Looking at the console it says I am logged in and also shows an error message: 404 - file not found for file: metamodel.json I tried creating a new page with just text on it for the app to open but experience the same behavior. I also tried a different app in 6.4.1 and had the same thing happen. This app was running fine before.  Does anyone know what would cause this or how to resolve?   Thanks, Tracy
3 answers

Could it be your browser cache causing issues? With the Chrome inspector open, click and hold on Chrome's refresh button and choose "Empty Cache and Hard Reload".


Check out the console in your browser. It could be a widget that is preventing your page from loading and sometimes the console reports errors that narrow down your search.


Do you have the correct redirect in your index file? I had something like this happen and my index page didn't look like this:


    <body dir="ltr">
        <div id="content"></div>
            dojoConfig = {
                baseUrl: "mxclientsystem/dojo/",
                cacheBust: "{{cachebust}}",
                rtlRedirect: "index-rtl.html"
            if (!document.cookie || !document.cookie.match(/(^|;)originURI=/gi))
                document.cookie = "originURI=/login.html";
        <script src="mxclientsystem/mxui/mxui.js?{{cachebust}}"></script>


I wish I could remember which piece it was missing, it might have been the mxui.js piece