SharpSvn.SvnRepositoryIOException: Commit failed (details follow):

Hi there, I am getting the following error when I merge a branchline into main line:   SharpSvn.SvnRepositoryIOException: Commit failed (details follow): ---> SharpSvn.SvnRepositoryIOException: At least one property change failed; repository is unchanged ---> SharpSvn.SvnRepositoryIOException: Could not execute PROPPATCH. ---> SharpSvn.SvnRepositoryIOException: PROPPATCH of '/1d69b349-1243-4ab0-9008-9c44a9209af4/!svn/txr/25-16/trunk': 207 Multi-Status --- End of inner exception stack trace --- --- End of inner exception stack trace --- --- End of inner exception stack trace --- at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, SvnException error, Object targets) at SharpSvn.SvnClient.Commit(ICollection`1 paths, SvnCommitArgs args, SvnCommitResult& result) at Mendix.Modeler.VersionControl.SvnConnector.PathClientDo(String workingCopyPath, Action`1 action) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 825 at Mendix.Modeler.VersionControl.SvnConnector.Commit(String projectDir, SvnCommitArgs commitArgs) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 777 at Mendix.Modeler.VersionControl.CommitWorker.DoCommit(IProject project, String message, RevisionMetadata metadata) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\CommitWorker.cs:line 188 at Mendix.Modeler.VersionControl.CommitWorker.CommitToRepositorySilent(IProject project, CommitState state, IProgressInfo info) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\CommitWorker.cs:line 146 at Mendix.Modeler.UIFramework.Progress.ProcessRunner.RunStep(Step step) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 81 at Mendix.Modeler.UIFramework.Progress.ProcessRunner.OnDoWork(Object sender, DoWorkEventArgs e) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.UIFramework\Progress\ProcessRunner.cs:line 61 at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e) at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument) I tried cleaning up my file directory using TurtoiseSVN but this does not work. Same goes for the Resolved option. I also tried merging the other way around (merge Main into my feature branch) but this results in te exact same error. I am using Mendix 7.21 and also tried 7.22 Any ideas on how to solve this issue? Thanks!    
2 answers

Same issue as


This situation is caused by a bug in the Modeler that exists in 7.19 and up. When merging a branch, the Modeler tries to automatically fix conflicts on the "svn:ignore" property. That property is where Subversion keeps track of files that should be ignored, i.e. on disk but not committed to the Team Server.

If there is both a change on the branch and on the main line in that property, the Modeler resolves the conflicts by simply combining both lists. However, we made the mistake of using Windows newlines instead of UNIX newlines and the Subversion server does not like this.

We will fix this bug in 7.23.0 and fortunately, there is a workaround that does not require upgrading. When you are in the state where you cannot commit the results of a merge, perform the following steps:

* Open the project folder via the Desktop Modeler by choosing "Show project directory in Explorer" from the project menu
* Right-click the white background of the project folder
* TortoiseSVN > Properties
* Double-click the "svn:ignore" line
* Copy all text by doing Ctrl+A, Ctrl+C
* Paste into a new document in Visual Studio Code (or another editor that understands newline conventions)
* In the bottom right, click on "CRLF" and select "LF" instead
* Copy all text by doing Ctrl+A, Ctrl+C
* Go back to window showing the "svn:ignore" property
* Paste there: Ctrl+A, Ctrl+V
* Click "OK"
* Click "OK"

You can commit again, from the Desktop Modeler!


Hi Tim,

Recently encountered this error while merging as well. I was able to "fix" it using the answer from this stackoverflow post:

You will need to have TortoiseSVN installed. Go to the project root directory, righ click on it and select: 
TortoiseSVN -> Properties. Then remove the svn:ignore property and try again.

Fair warning: While this worked for me I am not sure this will always get the intended result. Please make sure to solve any conflicts beforehand and be ready to revert if anything goes wrong. Good luck.