Failing to merge into 7.23.2. SVN exception: An existing connection was forcibly closed by the remote host.

Hi all, We have the main line on 7.8, the branch on 7.23.2. I'm trying to merge these together, so I upgraded the main to 7.23.2 and then tried to pull in the changes from the branch. That's when I run into: SharpSvn.SvnSystemException: Error retrieving REPORT (730054): An existing connection was forcibly closed by the remote host.   at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, SvnException error, Object targets)   at SharpSvn.SvnClient.Merge[TRevisionRange](String targetPath, SvnTarget source, ICollection`1 mergeRange, SvnMergeArgs args)   at Mendix.Modeler.VersionControl.SvnConnector.<>c__DisplayClass67_0.<Merge>b__0(ISvnClient c) in C:\jenkins-ci\workspace\AppStudio3.0-Build@2\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 872   at Mendix.Modeler.VersionControl.SvnConnector.PathClientDo(String workingCopyPath, Action`1 action) in C:\jenkins-ci\workspace\AppStudio3.0-Build@2\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 903   at Mendix.Modeler.VersionControl.RevMerger.SvnMerge(RevMergeState state, IProgressInfo info) in C:\jenkins-ci\workspace\AppStudio3.0-Build@2\modeler\Mendix.Modeler.Core.View\VersionControl\RevMerger.cs:line 310 I checked and removed the additional .launch lines, I've cleaned/unlocked both directories but still no luck. I've done this workaround mentioned here: I’ve tried port fix and advanced merge (when it allowed me to). Also tried to merge the other way around, and no luck. Any ideas? Thanks in advance!
3 answers

So if anybody ever runs into this, the solution we’ve gone with is to create a new main line branch (latest revision, v7.23.2). Then merge the branch into that main line branch and use that merged branch as the main line.


One more reason you may get this error (or mostly any other SVN error while merging) is because of a bad network connection. I would recommend to check your network connection (if it is slow) first incase you receive any connection error while merging. I have faced such errors a couple of times and every time bad connection was the culprit. As soon as I switched to a better network, the merging worked just perfectly.

Note that in my case both the branches were on the same modeler version.


In my case, it seems the project folder is locked. I use TortoiseSVN at the project folder, choose Clean Up and make sure you tick Break Write Locks. After that you can try Update again.