Working copy locked error when downloading project.

When I download the Main line of my project, after several minutes of downloading, I get the following message: SharpSvn.SvnWorkingCopyLockException: Working copy '[PATH]' locked. ---> SharpSvn.SvnWorkingCopyLockException: '[PATH]' is already locked.  I've encountered this message before, when committing/updating a project, but never in the context of downloading a fresh copy of a project.  My project folder is half empty, without a resources, userlib and widgets folder.  If I open the project, I get the message: "SharpSvn.SvnWorkingCopyLockException: '[PATH]' is already locked." When I issue an SVN Clean up, I can open the project, but the top bar says: "(Main line, private server)" Updating the projects results in conflicts on the resources, userlib and widgets folders. Does anyone have any ideas what can cause this behaviour & how to solve it?
2 answers

This usually happened to me when my backup software was locking the files while Mendix is still downloading the files (either during update/commit/checkout SVN files get updated).

I can prevent it by making my backup software stop. If you have any type of software running that might block files like:

- Backup software

- Antivirus 

- Anything else

You could just try redownloading the project a couple of minutes later or temporary stop the processes locking your files


Is there a way to pinpoint “the process locking the file”? I've stopped several processes but still get the same error.



I've downloaded the project in a newer version of the modeler, and somehow that's no problem. Then opening the project in the older version seems to work