Problem with Runtime

“Run Locally” produces the following error message in MX Studio Pro: Date: 2019-09-10 13:31:38.923, LogNode: M2EE, Message: An error occurred while initializing the Runtime: null Any idea how to fix this? Thanks, Willfried.  
2 answers

Did you already tried the other forum sollutions for this problem?





You have a problem with unique constraints in your database. i guess you upgraded your application to a newer Mendix version. You can go to the runtime settings and set the uniqueness check to runtime again (I guess that’s how it was before) or you need to cleanup your problems in the database. Mendix has a tool that can help with that, you can ask the support.

The Problem is that the runtime uniqueness validation not always worked. This causes associations in the DB that are not unique (an object associated to more than one other in a 1-1 association and stuff like this). To prevent this, newer mendix versions add constraints to the database. But if the problem already existed in your db, you are running into this error.