Merge conflicts

Good Morning, I am running into something that seems to be a merge conflict. But I can’t see anything. First of all I checked out mainline (I did a fresh checkout from teamserver. I was not updating a local version). I got following message: After clicking proceed, I got the following: After clicking Merge, it showed me this: I updated my model using “Update”. It worked. Now I tried to merge a revision from another branch and I was running into this: SharpSvn.SvnWorkingCopyException: One or more conflicts were produced while merging r2226:2248 into 'C:\Users\blaesiusa\Documents\Mendix\MyAppName' -- resolve all conflicts and rerun the merge to apply the remaining unmerged revisions    at SharpSvn.SvnClientArgs.HandleResult(SvnClientContext client, SvnException error, Object targets)    at SharpSvn.SvnClient.Merge[TRevisionRange](String targetPath, SvnTarget source, ICollection`1 mergeRange, SvnMergeArgs args)    at Mendix.Modeler.VersionControl.SvnConnector.<>c__DisplayClass67_0.<Merge>b__0(ISvnClient c) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 872    at Mendix.Modeler.VersionControl.SvnConnector.PathClientDo(String workingCopyPath, Action`1 action) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core\VersionControl\SvnConnector.cs:line 903    at Mendix.Modeler.VersionControl.RevMerger.SvnMerge(RevMergeState state, IProgressInfo info) in C:\jenkins-ci\workspace\AppStudio3.0-Build\modeler\Mendix.Modeler.Core.View\VersionControl\RevMerger.cs:line 351   Any Ideas on this?
5 answers

Mendix support figured out that this seems to be related to a bug in Mendix 7.23.3 – 7.23.7 in combination with collaboration turned on. They suggest to update to 7.23.8 and to turn off collaboration (Although they don’t know if this is even possible). Maybe that helps other people that have similar issues.


Hi Andreas, depending on the version of your project use Tortoise SVN (1.7 for Mendix Project <= 7.23.8) or Latest version (>1.9) for your 8.x.x project to resolve it. 

Sometimes it's a bit tricky, but TortoiseSVN will navigate you to the correct conflicted file.



That is a bad experience. Sorry!

Are you using the Web Modeler a.k.a. Studio at all? If not, then you should not hit the “Merge” button because you don’t want those changes in your project.

What happened to your project is that the old way of working with Studio was disabled and the new way was enabled by Mendix. This will cause the extra dialogs to appear. 

I don’t know what state your project is in now and I have never seen the exception you reported. I have Googled it and found that Subversion gives up merging a range of revisions if too many conflicts arise during that process. That is probably because of the state your project is in after the Merge from the Web Modeler. 

Can you try the following?

  • Close project
  • Discard the local state by using ToirtoiseSVN > Revert (if there is nothing important there)
  • Reopen project
  • Hit “Resolve later” if you see that dialog again
  • Try the merge you actually wanted to do

Install tortoise 1.7 (not the latest version!) and check in tortoise for merge conflicts.

Some conflicts are only visible outside the modeler.

But i may assume you already did this.

Sometimes i just remove the project from my local machine entirely and redownload to fix issues like this.


Sounds like an issue for a Mendix support ticket?