Uploading a self signed certificate for REST calls from the Sandbox

Hello, I am testing Mendix and currently trying to upload a certificate, so that HTTPS REST calls to my REST server are possible. When running the app locally, after having installed the certificate in the Desktop Modeler, this is possible. But when I try to make REST calls from the Sandbox, using the global IP of my REST server, it fails. I suspect that this is due to the fact that my REST server certificate is self signed. The documentation states that I need to upload the certificate under the Network tab at Developer Portal → Deploy → Environment. However, as you can see in the screenshot below, there aren’t any tabs except for the Deploy tab, which also lacks the environment section. Is this due to the fact that I use the free version? Kind regards Sam   EDIT: The initial problem could be solved, see my last comment
3 answers

Not possible in Sandbox, use your desktop modeler to test by adding the certificate into your settings


You are using a free version. You can find the network tab in the paid version and from there you can upload the certificate.

Another thing you can try is to go to Modeler. Under Settings > Certificates, upload the SSL certificate and use the “Run” option to run the app from cloud. That might work.


Thank you for your answers. I found a workaround for the initial problem (Mendix not being able to call my REST server):

1.) I created a dyndns-Domain for my REST-server
2.) I got a certificate for this server using Let’sEncrypt
3.) I put the dyndns-adress into each REST-call

Calling the dyndns-adress in the browser, it still says that the connection might be insecure, but given that it’s signed by a CA (Let’sEncrypt) AND that the certified name matches the URL, Mendix seems to be ok with it.

For anyone reading this wondering if Mendix accepts CA-signed pages where the certified name DOESN’T match the URL: It doesn’t, I tried.