Bug on objects creations with excel data import

Hello, I have a program that works fine most of the time, but sometimes I got a bug that I don’t understand at all.  What I do is : I create 2 objects (my main object, + a System.Filedocument object) via a microflow I let the user fill several attributes of the object, and import an excel file  When he clicks on a button in order to finish the process, the program does several things via multiple microflow calls (nested microflows) :  The first microflow tests if the fileDocument object contains the excel imported by the user, and via 2 excel importer templates it creates several objects linked to our main object, and does some calculations of the attributes with all the datas imported.   Then a second microflows is called to check if the fields are correctly entered,  Finally we go back to the previous microflow in order to change an attribute of the main object and commit it with events/refresh, and then we show a popup confirmation of the object creation. If needed I can put pictures of these microflows, but I am not sure that it is so relevant and I will explain why. The bug is that sometimes, when we click on the button in order to finalize the objects creation, the program seems to stop, or to block on a particular step. And it creates an empty object. So I tried to test again by debugging it online (the program is in acceptance environment), and then it worked perfectly. But until I did that, even with several basic tests, it didn’t work any time. Then I tried again without my breakpoints, and now everything works fine again.  So I presume that it is not due to the actions that I do in my microflow, because if yes, I cannot know which one since the debugger does’nt give me any information about the moment that could causes the bug.  Has anybody of you had a similar bug ?  Thank you in advance for your help with this issue.   Modeler version : 7.21.0 (not available in the selector below).
0 answers