How do disable auto-commit while editing the column(s) on Data Grid1 ?

Hi Team, How do disable auto-commit while editing the column(s) of Data Grid1, because of  through the ‘update button’ I have to update. Thanks !...    
2 answers

Unfortunately there is no way to disable autocommit at the moment. 

Either you need to use the editable data grid as is, or you can do it via your update button microflow.


You can achieve this in Mendix by disabling the "Auto-commit" option for the data grid widget and implementing custom logic to save the edited values only when the "Save" button is clicked. Here are the steps you can follow:

  1. Open the page containing the data grid in the Mendix Modeler.
  2. Select the data grid widget and go to the "Data source" tab in the properties pane.
  3. Under the "General" section, uncheck the "Auto-commit" option. This will prevent changes from being automatically saved when a user leaves a field.
  4. Add a "Save" button to the page, if you haven't already.
  5. Implement the "Save" button's on-click event to loop through the data grid's rows and save the edited values for each row that has been modified. You can use a microflow or nanoflow to implement this logic.
  6. If you're using a microflow, you can use the "Commit" action to save the changes to the database.