Datepicker validation message change from Invalid Date

Hello :)    I would like to know, if possible, if there is any way by which we could change this validation message →    from “Invalid date” to something else we like, or at least, if we use the datepicker for time picking only, to be “Invalid time”   Thank you :) 
6 answers

Hey Marcian-Petrut Bondoc-Popescu,


I am Jhansi!!

From the input you provide, it is invalid format.

For Invalid format entered: Mendix will use the system text as part of validation message.

For Valid format entered: We can make use of OC microflow and make use of custom validation message.


In the example you provided your expecting the system text to have a custom message. In order to do so please follow below steps:

  1. Go to System texts under the project application module.
  2. Find the Validation text for date
  3. And customise the message.

For mode detailed view, please check out below screenshot.


Hope you find it helpfull!




What am I missing? I’ve changed the system text, saved & rerun, I am confused about it. 


Btw, with my question I wanted a way, only if possible, but I am afraid not, by which I could specify the message only on some datepickers not all date pickers. Because I want for only time date pickers to show a time related message & for only date pickers to show a date related message or keep the one it is by default!


Thanks for the answer anyway, really appreciate it! 


Hey hi,

My configuration also includes mentioning the format on the field level.

Please recheck your date format and format example on the field level.



  1. Change the system text to what you want.
  2. Change the format on the field level, as your is date and time and you want it in different level.
  3. If need write a different on change microflow, which I mentioned earlier comment.
  4. Do a clean deployment directory

Reason: Sometime the changes are not reflecting so I do clean deployment directory and synchronize app directory


Hope it helps!!!


Tried all combinations possible of clean deployment & sync app directory. Even tried to set the date to not have custom format but still it is not working.





This is the attribute data type (date & time)


But it’s not only this. I’ve tested with multiple date & time attributes. It’s not working for those as well. Kinda weird ;)






So, I am not sure what you mean 100%, I think I get it. Anyway, I wanted to show that I do not have any input level validation or entity level validation. The input widget has the time format. The date is being saved correctly as expected.


I’ve tried the same with different date time attributes & input widgets so I could exclude the format & attribute cases. Still not working.. I will leave it as it is for now since it’s not that critical but it’s annoying. I am not sure if you can reproduce it on your side. Maybe I should try with a different studio pro version, I am not sure. I am using currently 9.24.4.