Problem with creating a theme for an App

Hello guys,   I'm working on customization for an App and I have a problem. I have created a theme by consuming Theme creator. When I finished a theme, I regularly imported a theme (Settings/Runtime/Theme/Import) and when I run the application I have those errors: 404 - file not found for file: styles/css/custom/false 404 - file not found for file: styles/css/lib/false My styling can be seen (Changes that I made for this specific theme can be seen when I run and view the app) but I've those errors in console and they are preventing me from adding and using styling in custom.css file. I used theme creator by looking into introduction videos ( and and . I've been searching for solutions but unfortunately I didn't find anything that could help me. Do you have idea how I can resolve this problem?  Thank you in advance, Aleksandar Alempic 
3 answers

I have had these errors in the past (support ticket #49129 ). But allthough these errors should not happen I still could use the theme and adjust it to my needs. Could you elaborate why it is preventing you to customise the custom.css file?

And file s support ticket anyway. The theme creator should not create themes which generates errors.





I had those errors once when my theme tried to import fonts with url 'false'. This was some mixup with the theme creator when you did not specify extra fonts, but only used the default. I think I read somewhere that it should be fixed.

Anyway, check your sass files for the typography section. I commented out the font familiy import section, because I did not need to include extra fonts.

//== Typography
//## Change your font family, weight, line-height, headings and more (used in components/typography)

// Font Family Import
/*$font-family-import:     false;
@import url($font-family-import);*/


Hello guys,

I found a workaround for this kind of errors. Error is caused because of non existing classes that appeared in mendix theme lib.css file. To be more precise error occurred because of missing:  

@import url(false);
@import url(false);

I copied all content from the lib.css from mendix theme file to standard default mendix lib.css file and I removed those above mentioned two lines of code. After that everything worked correctly. Now I have a styling that I created in mendix theme creator and I don't have mentioned errors that prevented me from using custom created css. 

I hope that this will help someone :) 


Kind regards,