Gulp Sass compiler in Menidx 8 stopped working

Hi All, I am working with Mendix 8 theming and after setting up Gulp & Sass found that Sass compilation stopped working. This is due to new theme folder structure in Mendix 8. I updated gulp.js file with latest folder structure (hoping soon there will be a latest version of ux-theming on GitHub) which resolved the compilation errors but deployment CSS file is still not getting updated for some reason. Every-time when I update my Sass files, they get compiled but I have to manually re-run project locally to see the changes.  // What is the name of the style folder in this theme folder? var sourceStyleFolder = 'theme/styles/web'; //Added /web // What is the name of the style folder in the deployment folder? var deploymentStyleFolder = 'styles/web'; //Added /web I tried both deploymentStyleFolder = ‘styles’ and 'styles/web' but no difference.  Did anyone in the community had same issue and managed to resolve this?  P.S: There is another folder under theme/styles called ‘native’  but I assume this is not required to be added in gulp.js. 
2 answers

Hi Mohammed,

Did you check this post:


Hello Mohammed, 

While I’m not familiar with Gulp, I’ve successfully compiled Mx 8 SASS with Scout using /theme/styles/web/sass as input and /theme/styles/web/css as output.

I’m assuming Gulp would require the same structure.

Hope this helps.