Rendering error prevents showing text area or text block

Hi guys, Showing a simple field in a screen worked like a charm before, but -after some Mendix upgrades- the application stopped showing the field  for the user to edit. Inspecting in the browser shows that the application could not render the container of the field because of the error “react-mount-point-unstable”. Google learnt that the container is detached from the data the UI wants to show somehow. Anyone stumbled upon this one or has any suggestions how to solve it? My only hope is to upgrade to a higher Mendix version (I'm on 7.23.3 now) and that the problem will be solved then.
3 answers



We got a solution after Mendix took a deeper look into this issue of not rendering a text field. The case was that the container in which the field was shown, was nested within another container (multiple times). The properties for this outer container were that it was non-editable. This was inherited to the container of the non-rendered field and for that reason React seemed to show the field (text area or text block) with a length of zero positions and generated the error.

Thus the solution was quite simple: Make the outer container editable and any containers within non-editable where needed. The container with the non-rendered field become editable now and the field is rendered.

It's like my motto: Simplicity, handled in the right way, becomes elegance!


running into same problem

this causes my “zebra list” to not work because every cs_container is seen as the first in the series. :( 

mine also inserts a scipt after every container? no idea what it is.