Object cant be updated as it does not exist anymore in Mx7

Hi guys, I've problem with error 'Object can't be updated as it does exist anymore'. I was doing the migration of my application from Mx6 to Mx7 and I found a bug in Mx7. Something strange happens, my functionality works in Mx6 and It doesn't work in Mx7. I was doing the debug process parallel within Mx6 and Mx7 and in Mx6 debug process goes further on to the end and functionality works, but in Mx7 modeler I got a problem which I will describe: While I was going through the debug process in Mx7 modeler, my object exist in memory (I could see him in tab 'Variables') and for some reason when my object comes to the action 'Commit', the debug process is automatically stopped and in browser I got the popup window which says: 'Object of type '------' with guid 'id from memory' cannot be updated, as it does not exist anymore'.  I have some ideas, but they didn't finish good :). Also I saw that this error was happening in the past (Within Mx4 and Mx5) and that is resolved with Mx6 (Modeler 6.10.3 I think). Can someone help me with the idea how I could resolve this problem? :)  Kind regards, Aleksandar  
3 answers

Hi Aleksander,

Might it be that you commit the object twice in your microflow? I think you refer to the fix in 6.10.6:


And later on a simulair issue was fixed again in 7.2(third bullet):


If the same situation applies to you, you could create a ticket for it again.

Else a bit more information on your microflow setup and ideas you already tried would be great.



I while a ago I have submitted a similar bug to Mendix in the Mendix Email module which is not solved yet. I hope they will fix this soon.


I found where is the problem. The problem is with event handler ('Before Commit') which is called within action 'Commit' (Because action 'With events' is 'Yes'). When I put 'With events' to 'No' and call microflow (which is event handler)  before action 'Commit' everything works fine. In other words when I simulate action 'Before Commit' with calling event handler microflow directly in my current microflow (before I committed the object) everything is fine.    

Kind regards,