Retrieve all the data from an object when editing

Hello, I am currently facing an issue regarding editing objects, where I cannot retrieve all the data when editing a certain object. In my case, I have th object called PlanningSchema, which contains a date, a Start Time and and End Time, along with a location that is shown below the table.   On Editing this object, I canno retrieve the location whatsoever. I have tried to do a custom microflow to somehow retrieve the location together with the PlanningSchema, with no much success. All I can see on editing the object is this :  And this is my Domain Model :    Any ideas would be very much appreciated, thank you! Quick edit : It appears that only the text is retrieve, but I want it to show in the reference selector as well.
1 answers


Make sure you data Location entity data in your database. 


If data exist and still doesn’t display the data  in the Location dropdown then check the access rules in the Entity. (i.e, as a which user role you are trying to edit the Planning Schema & choose Location information) 


Hope it helps!