Mendix Studio Css not working properly (mendix starting point project used)

When I start a blank app I can choose the Asset Manager as a starting point. In mendix7 this gives a neat styling (dark blue/yellow), but this is broken in StudioPro8. I tried starting a blank app in modeler versions 8.5.0 and 8.0.0, and tried by converting from 7.23.3. All show a broken styling in local preview.   Question/need help: - Is this due to StudioPro8x conversion not implementing the styling correctly? - Is this due to the starting point provided not being converted correctly? (default conversion by Mendix did not yield correct Atlas 2.0 instructions)   Attached are the Starting point preview, the runtime for 7.23.3 and the runtime for 8.0.0 (same for 8.5.0)
2 answers

Yes, this does not seem right. It gets even more funnier when downloading Atlas UI resources. I would create a support request because the current package seems to be broken.








I got respons from support, and like to share with you for other developers seeking guidance with this issue.


The starting point app is a shared resource between different Mendix versions.

Basically the advice from Mendix is that we  to follow the troubleshooting guide when using Mendix8xx:


Quotes from support (from 2 replies):

-first suggestion would be to take a look at the following documentation, which may provide you with a path forward:

-  the default starting point app uses an older Atlas UI framework, which is compatible with versions prior to Studio (Pro) v8.x.  The Atlas UI Framework used in Mendix Studio (Pro) v8.x is not backward compatible with versions v7.x and lower.  This means the starting app has been created with the Atlas UI Framework that will work for all 3 versions, just in v8 it requires some changes when upgrading to the latest GA versions.