SFTP module version 9

Hi all! We are making use of the beautiful SFTP module published by Arjen on Mendix version 9.3.0, but are encountering certain difficulties. I would like to share our experiences in the hope to find an answer. Firstly, we receive the following validation message when generating a new RSA key (It breaks down on other key types): Could not read key pair from: [PrivateKeyReaderResource] java.io.InputStreamReader@465adec8 Secondly, when trying to connect without 'strict hostkey checking' and without 'use key' then the following error is received: Unable to connect: Could not verify `ssh-dss` host key with fingerprint `0c:b9:fe:ac:55:40:8a:cc:0b:17:eb:47:46:c9:02:61` for `xx.xx.xx.x` on port 22 Details: com.mendix.systemwideinterfaces.MendixRuntimeException: net.schmizz.sshj.transport.TransportException: [HOST_KEY_NOT_VERIFIABLE] Could not verify `ssh-dss` host key with fingerprint `0c:b9:fe:ac:55:40:8a:cc:0b:17:eb:47:46:c9:02:61` for `xx.xx.xx.x` on port 22 at com.mendix.basis.actionmanagement.ActionManager.executeSync(ActionManager.scala:84) Googling brings me to the following answer on stackoverflow, but I am not quite sure how to proceed. Would anyone else have a clearer understanding of the issue and a possible solution? https://stackoverflow.com/questions/7873909/dealing-with-host-key-not-verifiable-could-not-verify-ssh-rsa-host-key-with Mil gracias
2 answers

Hi Xiao Cao,

I encoutered the same issue with this version of the SFTP module in Mendix 9. 

What did the trick for me, was to first set ‘Strict host key checking’ to Yes. Then, obtain the host key by cling the button ‘obtain host key’ and retrieve this key. When this is done, set the boolean ‘Strict host key checking’ to No again. Then try to connect again. This solved the issue for me. I hope it's helpful.




Hi Xiao Cao,

We also faced this problem recently and solved it by deleting SFTP configurations and readding them again. You get option to obtain host key which you can use during authentication. 

We decided not to use key and its working for us as expected with normal username/password.