Checkbox uneditable

To whom it may concern, I am trying to make the checkbox editable, meaning I can put a check mark on the side upon clicking. However, when I run the app locally, the checkbox area is grayed out, and I couldn’t click on it. Here’s a screenshot of my checkbox properties and what it looks like when it runs on localhost. I’ve made sure that Editability is on default but it’s not working still. Are there any other underlying causes to this problem? I tried looking through some of the documentations on Mendix, but I couldn’t find anyone who’s facing similar problems.  
1 answers

Hi Jason,

Like to add few check points to find the cause for your problem,

  1. Make sure you have enough read / write access for the user on the entity.
  2. If check box inside a data view or list view make sure the object is created and available in the session. If you get from association make sure its created and available the same.
  3. If its inside a list view make sure to enabled editability of the list view.
  4. If any on change events configured make sure to have enough access for those.
    If none of the above helped . Please send the domain model and the complete page details for more information

    Hope this helps! Thank you.