Unlink widget from appstore (widget is not in appstore anymore) (fixed)

Hi, We have a pretty large project and are currently in the process of upgrading from Mendix 7 to 8. The project uses a widget called ‘Help Text Viewer’ over 800 times. After upgrading to Mendix 8 we get the error: “widget is not compatible with this Mendix version. Update the widget with the latest version from the App Store”. However, the widget is not available in the app store anymore.  Somehow Mendix remembers that this widget is from the appstore. If I overwrite this widget with a clean, new boilerplate widget with the same widget name, Mendix will still give the error. Please see screenshot below.  In this screenshot the widget is replaced with a completely clean hello world boilerplate widget for Mendix 8. If I change the ID of this widget, the error disappears. So Mendix remembers this ID and will give the error because this widgets ID is linked to the appstore. How can we “unlink” the widget from the appstore so that we get our own version of this widget. Ps. I cannot change the ID of the widget because then I would need to go over all 800 usages and replace the broken widget with a new one. I'd rather keep the same ID so it automatically replaces (which works fine, done this with other widgets).    UPDATE: fixed After a long struggle I fixed it by updating the version number in the widget MPK file to an crazy high number. I already tried this before and updated to version 2.0.0 for example (was 1.0.0) but that didn't help either. Now I updated the number to 99.9.9 and the error went away. Very strange because if I clicked the error message Mendix would say “Widget is not found in appstore” so not sure why Mendix would accept this version number and not a lower one. Anyway it's fixed. 
2 answers

Great that you solved it. Maybe there is an even better solution though:

  • unzip the widget
  • remove the appstore.id and zip it again.

My guess is that it will no longer treat it like a Mendix appstore app.


I might be missing something here but why not adjust that widget so it is compatible? So just copy the widget over to another place and change the extension to .zip and extract everything. Then make your adjustments and just zip it up again and place it back in your project files.

Other option might be to check the model SDK out to see if you can adjust it with that.