Rich Text widget issues

Hi,   I'm having issues with the Rich Text widget (which is based on CKeditor).   When editing I can't use any of the buttons on the (basic/standard) toolbar to format. There is a click pointer on the buttons when I hover, but nothing happens when clicked. Using the keyboard shortcuts does work. I've tried Chrome and Edge and local en MxCloud. It simply doesn't work. In my console I'm getting errors like:   Uncaught (in promise) {message: 'A listener indicated an asynchronous response by r…age channel closed before a response was received'}   or   mxui.js?637988393511888070:66                TypeError: Cannot read properties of undefined (reading 'getComputedStyle')     at (ckeditor.js:100:349)     at $.getDirection (ckeditor.js:123:386)     at $.setup (ckeditor.js:377:441)     at $.a (ckeditor.js:1276:243)     at ckeditor.js:28:213   Other thing is that when I want to edit an existing string, the Rich Text widget shows an empty editor space, but in fact there is data in the attribute when using a text area to inspect.      The project is on 9.12.5 and I've tried widgets 2.0.0 and 2.0.1. I've done a clean deployment directory to get rid of any old versions of the CKEditor which was in use in the project.   Does anyone know what could be wrong?  
1 answers

Hi Sjors,


I also encountered this error and have no idea what happens exactly there.

But I saw they released on 30 Oct 2023 a new version of the widget, which you can find here:

This version fixed the issues for me. Still curious to find out what is the problem.