File dropper widget causes error: this._reactRoot is Null in Mendix 10

Hi can anyone help me with the following:   The file dropper widget ( generates an error in de console causing the system to freeze / stop working.   this._reactRoot is null                  
5 answers

 Dear Leon & Marc,

  1. Make sure you have the latest version of the File Dropper widget installed

  2. Double-check that you have properly configured the File Dropper widget

  3. Verify that you have placed the File Dropper widget within a container or layout that is compatible with it. Some widgets require specific parent containers or layouts to function properly. 

  4. Incorrectly modifying the widget's code can also lead to unexpected behavior and errors

  5. If the issue persists, consider reaching out to the widget's developer or the Mendix community for support. They may be able to provide more specific assistance or insights into the cause of the error.


Yes (it was fixed in 10.1 also)


Hi Leon, 


Have you managed to deal with this error? I am currently facing an identical problem :(


To answer your questions:
1. yes, the latest version of File Dropper from the Marketplace is installed
2. of course I checked, however as I wrote in my post (here: LINK) the same configuration previously worked on one of the older versions (backups) of my application
3. the widget is only placed in the layout grid as a parent
4. the widget has not been modified in any way by me

What is at all specific to this problem is that entering the form (or, I think, using the File Dropper for the first time in a particular browser tab) the first time does not cause the problem.

In this scenario it works like this:
1. from list view (or data view - I checked both scenarios) I go to the edit page of an entity to which a file is attached in a 1:1 relationship (in this scenario the file is set)
2. the edit proceeds without problem, the File Dropper works, the file can be changed (the scenario works the same for both variants, that is the file is changed or not)
3. I finish the edit (with or without saving - the effect is the same)
4. the page closes, I return to the page from which I started the form
5. another attempt to enter this form ends in freezing

What's more: trying to open any other File Dropper page (using even a different entity) after implementing steps 1 to 4 in the same browser tab ends exactly the same way. It's as if File Dropper has become a... a one-time only widget :)

The strangest thing is that the problem is solved by refreshing the page in the browser tab - I mean, if we go from step 1 to 4 and before I execute step 5 refreshing the page (but thus returning to the homepage) and repeating the steps does not cause the problem.

In another scenario, I also checked the version where I repeat steps 1-4 in separate browser tabs. No error occurs in any window (unless I do step 5 in the same tab).

The problem occurs in exactly the same way in Opera and Edge.

Occasionally, but it's hard for me to pick out a scenario where this always occurs, and I have a suspicion that the cause may be something else completely, probably not File Dropper's itself, and it's probably a coincidence (but I prefer to mention it preventively), the warning "Failed cluster management action: cleanup orphaned files." appears in the console. - although I stress that it appears rarely


Ok, I have found the only solution so far.

I exported the app package to a new file without data and imported it into Mendix 10 beta 2 and so far everything works.

I feel a bit sad about the test data I entered which allowed me to check the correctness of the functionality of the whole app, but trying to improt the app file with data into M10B2 resulted in a database incompatibility issue when compiling the site. 

So I would recommend, until Mendix 10 is fixed, going back to beta 2. (Going back to 9.24.3 unfortunately didn't work for me).